view net.h @ 1597:75aa418d0227

Use better names for "Guide" button on PS and Xbox controllers, handle d-pad directions in get_button_label
author Michael Pavone <pavone@retrodev.com>
date Wed, 25 Jul 2018 09:35:46 -0700
parents 4f94e0f90c83
children
line wrap: on
line source

#ifndef NET_H_
#define NET_H_
#include <stdint.h>

typedef struct {
	uint8_t ip[4];
	uint8_t net_mask[4];
} iface_info;

uint8_t get_host_address(iface_info *out);

#endif //NET_H_