Opened 5 years ago

Closed 5 years ago

#29 closed defect (fixed)

Blank out non-drawn parts of the window

Reported by: Sik Owned by: mikepavone
Priority: major Milestone: 0.5.1
Component: Genesis/Megadrive Version: 0.5.0
Keywords: Cc:

Description

When the screen doesn't fit perfectly within the window (i.e. they have different ratio), parts of the window are not drawn. The problem is that then whatever garbage was there in video memory gets displayed, and depending on the case it may outright become an extremely annoying flickering mess.

This seems to be a recent issue since it's only happening now that I updated to tip (and you know I usually don't lag behind much on updates). Before it used to just cover those areas with black.

Change History (3)

comment:1 Changed 5 years ago by Sik

Wait I see what's going on: OpenGL now is disabled by default if it's not in the configuration (it didn't have a setting before). With OpenGL turned on, it behaves as usual. With SDL2, it does the flickering. So it's an issue with the SDL2 backend.

comment:2 Changed 5 years ago by mikepavone

  • Milestone set to 0.5.1

comment:3 Changed 5 years ago by mikepavone

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.